Page 1 of 1

No IPv6 routing specifically on Galaxy Tab S6

Posted: Thu Jan 02, 2020 12:49 pm
by hopkins35
Hi I've been using your app for connections to my SSTP VPN server using several devices with no problems and have been able to route using both IPv4 and IPv6. I've just purchased a Samsung Galaxy Tab S6 but am finding that although I've setup the connection in the same way (even tried restoring a backup from the working devices) it won't route IPv6 correctly, the link-local address of the server is pingable from the client and likewise the client's link-local from the server.

Upon further investigation (using 'ifconfig') I've noticed that the global address assigned to the tunnel doesn't match that assigned by the server, the prefix is assigned correctly but the suffix doesn't match that reported as the IPv6CP local address in your client software.

I should also add that the device works correctly with IPv6 on a local network, this problem only occurs when using the SSTP VPN app.

Thanks in advance

UPDATE: I have added the log and a paste from the ifconfig command in terminal emulator. For some reason the tunnel is being assigned two link-local IPv6 addresses, one of which matches that from the client app and can be pinged, and the previously mentioned erroneous global address!

Re: No IPv6 routing specifically on Galaxy Tab S6

Posted: Thu Jan 02, 2020 3:27 pm
by admin
The SSTP protocol configure only the local IPv6 address (fe80::X:X:X:X:X:X:X:X). The global addresses should be configured by the OS using the Router Advertisement messages.
So, seem that your device doesn't configure the global addresses correctly.

Re: No IPv6 routing specifically on Galaxy Tab S6

Posted: Thu Jan 02, 2020 3:35 pm
by hopkins35
admin wrote:
Thu Jan 02, 2020 3:27 pm
The SSTP protocol configure only the local IPv6 address (fe80::X:X:X:X:X:X:X:X). The global addresses should be configured by the OS using the Router Advertisement messages.
So, seem that your device doesn't configure the global addresses correctly.
Thanks for your reply, I've attached the log from the client in my first post, interestingly the tunnel is being assigned 2 local IPv6 addresses, my other devices are only assigned 1.

Do you think this is something to be pursued with Samsung then?

Thanks

Re: No IPv6 routing specifically on Galaxy Tab S6

Posted: Thu Jan 02, 2020 4:06 pm
by admin
The app assing only the local address received by the server, so the other local address is assigned by the OS.
Yes, in my opinion the problem is on the Samsung ROM