Don't route local network. Not working

Support requests about VPN Client Pro
Post Reply
airdog
Posts: 3
Joined: Sat Apr 03, 2021 8:48 pm

Don't route local network. Not working

Post by airdog »

I'm using the wireguard protocol and until 2 updates ago never had a problem with this option (tried global, for interface only and both global and interface) and still can't access local network.

The rest is working perfectly as usual. Uninstalled and re installed, still no go.

Android 10 on Samsung Galaxy a 31.

Any hints would be greatly appreciated.

Thanks

admin
Site Admin
Posts: 682
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: Don't route local network. Not working

Post by admin »

Please, can you post the screenshot of the routing TAB?

airdog
Posts: 3
Joined: Sat Apr 03, 2021 8:48 pm

Re: Don't route local network. Not working

Post by airdog »

Sorry for the blurring but my VPN is private. Not too hot on posting this info for the greater public.
My local network is on 192.168.1.0. Tried adding it in there with the result that nothing worked...

As already said apart from the local net not being reachable everything else works fine.

I have exactly the same setup on another Android machine with exactly the same routing table and it works fine AND the local network is reachable. It wasn't for about 2 weeks after 2 updates ago and then suddenly, without me changing anything it started being reachable again.


Screenshot_20210405082604.jpg
Screenshot_20210405082604.jpg (388.73 KiB) Viewed 198 times

admin
Site Admin
Posts: 682
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: Don't route local network. Not working

Post by admin »

No problem, you were right to blur the addresses.

The problem should be related to the IPv6 route ::/0
Unfortunately on latest devices this route catch also the IPv4 packets.

You can fix the problem in two ways:
  • 1. If you only want drop all IPv6 packets follow these steps:
    • tap on top left icon
    • tap on "Global options" icon
    • tap on "VPN options"
    • select "Block unconfigured IPv4/IPv6 protocol"
    • save the changes
    • edit the VPN profile
    • tap on "Interface"
    • remove the IPv6 address
    • go back
    • tap on "Peers"
    • tap on peer address
    • remove ::/0 from allowed IPs
    • save the changes
  • 2. if you want route also the IPv6 packets follow these steps:
    • edit the VPN profile
    • tap on "Peers"
    • tap on peer address
    • change the Allowed IPs ::/0 to 2000::/3 (this will route all public IPv6 addresses, if needed you can add also other specific IPv6 subnets)
    • save the changes

airdog
Posts: 3
Joined: Sat Apr 03, 2021 8:48 pm

Re: Don't route local network. Not working

Post by airdog »

Ok thanks. Tried the second method first, didn't work because although I saved the changes they were reset every time.
Tried the first method and that worked.

Thanks again, much obliged :)

Slipi089
Posts: 14
Joined: Mon Nov 02, 2020 7:32 pm

Re: Don't route local network. Not working

Post by Slipi089 »

I don't think it has anything to do with the device. Since I already have the same problem and it works with the official Wireguard client without having to change anything. It has also worked with an older version of VPN Client Pro. Would be nice if the developer could perhaps look again at what exactly it is. As I said, the configuration with ::/0 works with the official client.

admin
Site Admin
Posts: 682
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: Don't route local network. Not working

Post by admin »

Slipi089 wrote:
Wed May 05, 2021 1:50 pm
I don't think it has anything to do with the device. Since I already have the same problem and it works with the official Wireguard client without having to change anything. It has also worked with an older version of VPN Client Pro. Would be nice if the developer could perhaps look again at what exactly it is. As I said, the configuration with ::/0 works with the official client.
The official WireGuard client doesn't have the "Don't route local network" option, so I don't understand how you could do this test.
Anyway I just did some tests with the WireGuard official client and the behavior is identical: when adding ::/0 to the allowed ip, all the IPv4 packets are forwarded too

Slipi089
Posts: 14
Joined: Mon Nov 02, 2020 7:32 pm

Re: Don't route local network. Not working

Post by Slipi089 »

I mean by working, that it works right away with the import of the config. And as the previous speaker has already written, it worked without problems with a previous version of vpn client pro.

admin
Site Admin
Posts: 682
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: Don't route local network. Not working

Post by admin »

Slipi089 wrote:
Wed May 05, 2021 5:44 pm
I mean by working, that it works right away with the import of the config. And as the previous speaker has already written, it worked without problems with a previous version of vpn client pro.
Whenever a new version of Android is released there are almost always changes in the behavior of some Android's API. Usually these changes are only applied to apps that target (targetSdkVersion) the new version, while apps that target older Android versions run in compatible mode and work as if they were installed on an old version of Android.
The current version of the app targets the latest version of Android and therefore on the latest versions of Android it works differently.

Slipi089
Posts: 14
Joined: Mon Nov 02, 2020 7:32 pm

Re: Don't route local network. Not working

Post by Slipi089 »

sounds plausible and is also somehow annoying :cry:. but thank you for the answer.

Post Reply