On Demand - No network after disconnect

Support requests about VPN Client Pro
trollmar
Posts: 6
Joined: Fri Dec 04, 2020 7:52 pm

On Demand - No network after disconnect

Post by trollmar »

Hi,

Im new to your app. Looks very promising :-)

I try to figure out how "Connect on Demand" works.
I would like to disconnect after a certain time of inactivity.

Under Global Options / VPN Options i configured "DISCONNECT WHEN VPN IS INACTIVE" with 30 sec + 400 Bytes
With this Settings it disconnects the vpn after 30 seconds.


But all traffic is blocked after the disconnect. I couldn't reach anything else.
What could be the problem or misconfiguration with this behavier?
Thx

admin
Site Admin
Posts: 643
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: On Demand - No network after disconnect

Post by admin »

Hello,

thank you for using the app.
Are you sure that the VPN is disconnected?
Can you post the VPN log?

Here the steps to export the log:
  • start the app
  • tap on VPN profile name
  • tap on LOG tab
  • tap on top rigth icon with 3 dots
  • tap on "Export log"

trollmar
Posts: 6
Joined: Fri Dec 04, 2020 7:52 pm

Re: On Demand - No network after disconnect

Post by trollmar »

Hi,


The notification write "On Demand Monitor" stop
The VPN Pro Client App showed that the vpn is disconnect
The log didn't print a a disconnect to my vpn .. :shock:

Here is the log (modified with *** )

Code: Select all

2020-12-05 22:26:13 VpnClientPro-google-api27-release-1.00.62 (23010062)
2020-12-05 22:26:13 Connecting request by on demand (192.168.10.1)
2020-12-05 22:26:14 Unrecognized option or missing or extra parameter(s) in /data/user/0/it.colucciweb.vpnclientpro/files/temp/cb588f21-6b0b-4252-bc5b-7271ff6b08e6.conf:11: block-outside-dns (2.4.9)
2020-12-05 22:26:14 OpenVPN 2.4.9 android-arm64-v8a [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Nov 28 2020
2020-12-05 22:26:14 library versions: OpenSSL 1.1.1h  22 Sep 2020, LZO 2.10
2020-12-05 22:26:14 TCP/UDP: Preserving recently used remote address: [AF_INET6]64:ff3b::39f7:9a6b:7412
2020-12-05 22:26:14 setsockopt(IPV6_V6ONLY=0)
2020-12-05 22:26:14 UDPv6 link local (bound): [AF_INET6][undef]:1194
2020-12-05 22:26:14 UDPv6 link remote: [AF_INET6]64:ff3b::39f7:9a6b:7412
2020-12-05 22:26:14 [myadress.org] Peer Connection Initiated with [AF_INET6]64:ff3b::39f7:9a6b:7412
2020-12-05 22:26:15 TUN/TAP device  opened
2020-12-05 22:26:15 Initialization Sequence Completed
And a screenshot
Screenshot_2020-12-05-22-30-52-458_it.colucciweb.vpnclientpro.jpg
Screenshot_2020-12-05-22-30-52-458_it.colucciweb.vpnclientpro.jpg (45.48 KiB) Viewed 200 times

thx for help!

admin
Site Admin
Posts: 643
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: On Demand - No network after disconnect

Post by admin »

To enhance security, the app runs the VPN's native code in a dedicated process controlled by another service running in the main process.
In my opinion your device kills the native process without leaving the option to clean up the TUN interface, so the VPN is shown disconnected but the TUN routes are still in use.
Perhaps the problem is related to Android's battery optimization.
Please, try changing your Android settings to exclude the app from battery optimization.

trollmar
Posts: 6
Joined: Fri Dec 04, 2020 7:52 pm

Re: On Demand - No network after disconnect

Post by trollmar »

hi.
i tweak everthing in miui to no battery optimization for vpnclientpro.

doeen't solve the Problem .

but i discoverd it in more detail.

the problem with no net is only under mobil network. :o


if i'm in my wlan and deactivate "deactivate when the wifi is connected to these ssid".. then the app work as aspected.
vpn connects and disconnect ..no problem at all.

with the same setup but mobile network on (wifi off) , the problem comes back.

any idear?? i would like to use the app :geek:

admin
Site Admin
Posts: 643
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: On Demand - No network after disconnect

Post by admin »

please, can you post the screehshot of the auto connect and on demand settings?

trollmar
Posts: 6
Joined: Fri Dec 04, 2020 7:52 pm

Re: On Demand - No network after disconnect

Post by trollmar »

i dont use auto Connect
Screenshot_2020-12-09-12-27-16-809_it.colucciweb.vpnclientpro.jpg
Screenshot_2020-12-09-12-27-16-809_it.colucciweb.vpnclientpro.jpg (173.52 KiB) Viewed 169 times
Screenshot_2020-12-09-12-26-52-328_it.colucciweb.vpnclientpro.jpg
Screenshot_2020-12-09-12-26-52-328_it.colucciweb.vpnclientpro.jpg (177.39 KiB) Viewed 169 times

dissabled ondemand when im not testing.

admin
Site Admin
Posts: 643
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: On Demand - No network after disconnect

Post by admin »

In the meantime I am also giving support for another similar problem and maybe the problem is related to the IPv6 protocol.
By defalut the IPv6 is blocked until is added at least one IPv6 route.
Please, can you follow these steps and tell me if the problem is solved?
  • start the app
  • tap on top left icon
  • tap on "Connect on demand" button
  • tap on configured VPN list entry
  • tap on "+" button
  • select "IPv6"
  • set destination to "fc00::1/128" and tap on OK button
    this is a dummy route used only to enable the IPv6 protocol
  • save the changes
This is only a test, in the next app version the IPv6 will be enabled also without any IPv6 route

trollmar
Posts: 6
Joined: Fri Dec 04, 2020 7:52 pm

Re: On Demand - No network after disconnect

Post by trollmar »

Hi,
Thx for helping!!!

.. unfortunately i couldn't test it any longer...
...7 Days are not enough for testing when there are more problems ;)

In my test cycle i also tested on Stock Android 8. Could get it to work either.
So it couldn't be only MIUI. My first idea was: Routing problem!

I would like to test again. Is there a chance to get 7 days again?
When it works i would love to pay as a subscription or Lifetime.
best regards

admin
Site Admin
Posts: 643
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: On Demand - No network after disconnect

Post by admin »

trollmar wrote:
Thu Dec 17, 2020 9:07 pm
Hi,
Thx for helping!!!

.. unfortunately i couldn't test it any longer...
...7 Days are not enough for testing when there are more problems ;)

In my test cycle i also tested on Stock Android 8. Could get it to work either.
So it couldn't be only MIUI. My first idea was: Routing problem!

I would like to test again. Is there a chance to get 7 days again?
When it works i would love to pay as a subscription or Lifetime.
best regards
Please, check your private messages

Post Reply