Having some trouble with autoconnect

Support requests about VPN Client Pro
Post Reply
thepick
Posts: 2
Joined: Sun Sep 08, 2019 12:57 am

Having some trouble with autoconnect

Post by thepick » Sun Sep 08, 2019 2:02 am

Good morning,

Running Android 9.0 on a Galaxy S8 and using the hide.me VPN provider. I don't have a custom ROM, but my phone is rooted. I just purchased the Pro version of the app, and my goal is to have the app pause when the mobile network/WiFi drops and resume when the mobile network/WiFi is active again.

Problem: Once connected, I press airplane mode and wait a few seconds and the app pauses as expected. When I press airplane mode again to re-enable the internet I get a little exclamation point beside my WiFi icon and the app stays paused. The internet won't work again until I disable the VPN manually. It seems that the app interferes with the phone reconnecting to the WiFi, and without the WiFi the app won't resume.

Here's what I've done so-far:

With the VPN disabled, under the Auto connect settings in the app's main menu I clicked on the VPN profile I'd like to have auto connect. I checked:

Connect when the mobile connectivity is up
Pause when the mobile connectivity is down
Connect when the WiMAX is up
Pause when the WiMAX is down

After checking those off, pressing save, and then exiting to the Auto connect menu again, everything appears normal: The Boot-up/Always-on VPN shows the server I'd like to connect to, the auto connect monitor's Status shows that it is running, and the Auto connect VPN profile shows the settings I just checked off for the server.

Any assistance would be appreciated. Thank you!

admin
Site Admin
Posts: 463
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: Having some trouble with autoconnect

Post by admin » Mon Sep 09, 2019 7:09 am

Hello,

this behavior is very strange.
The system should send a notification about the connectivity change, but in your case this not happen.
This seem a bug of the Android ROM used by your device.
Maybe the problem is related to the Android's VPN setting "Block connection without VPN"
If you use this option, try to disable it.

thepick
Posts: 2
Joined: Sun Sep 08, 2019 12:57 am

Re: Having some trouble with autoconnect

Post by thepick » Mon Sep 09, 2019 12:53 pm

Thank you for your prompt reply. In the settings I unchecked:

Connect when the WiMAX is up
Pause when the WiMAX is down

and, instead, checked:

Connect when the WiFi is connected to these SSID *any*
Disconnect when the WiFi is down

That seems to have done the trick, and now the VPN connection is persistent when switching between mobile and WiFi, as well as when disconnecting and reconnecting via Airplane mode.

Cheers, and thank you for designing such a well-built app. Best money I've spent in a while. :D

admin
Site Admin
Posts: 463
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: Having some trouble with autoconnect

Post by admin » Mon Sep 09, 2019 1:20 pm

you're welcome.
Thanks for the purchase and for the workaround.

Post Reply