Connectivity change detected: WiFi - <unknown ssid>

Support requests about VPN Client Pro
Post Reply
usadream
Posts: 2
Joined: Mon Mar 23, 2020 5:41 am

Connectivity change detected: WiFi - <unknown ssid>

Post by usadream »

First of all, thank you for the great app. The only issue I have is, that the wireguard VPN does not disconnect automatically when connected to the home wifi, even if the SSID is selected in the auto connect exception list (see screenshot). The app doesn't seem to recognize the SSID the phone (Samsung Note10+, Android 10 original) connects to. Is there a known fix to this I have to change on the router or the phone? (Btw. even selecting "Disconnect when the mobile connectivity is down" doesn't fix the issue).

Thank you for ur support
Thomas

Log:
2020-03-22 16:45:03 Connectivity change detected: WiFi - <unknown ssid>
2020-03-22 16:45:03 The connectivity is changed.
2020-03-22 16:45:03 Restarting...
2020-03-22 16:45:05 Add peer x.x.com[x.x.x.x]:x
2020-03-22 16:45:05 set keep alive to 60
2020-03-22 16:45:05 -> 0.0.0.0/0
2020-03-22 16:45:05 -> ::/0
2020-03-22 16:45:05 Send handshake (1) to x
2020-03-22 16:45:05 Handshake with x completed
2020-03-22 16:45:05 Connected
Attachments
Screenshot_20200323-065902_VPN Client Pro.jpg
Screenshot_20200323-065902_VPN Client Pro.jpg (291.07 KiB) Viewed 735 times

admin
Site Admin
Posts: 555
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: Connectivity change detected: WiFi - <unknown ssid>

Post by admin »

Thank you too for using the app
On latest Android versions the WiFi SSID can be get only if the App has the Location permission and the Android's Location (GPS) feature is enabled.
Please try to open Android's settings, check the app permission and enable the Location feaure

usadream
Posts: 2
Joined: Mon Mar 23, 2020 5:41 am

Re: Connectivity change detected: WiFi - <unknown ssid>

Post by usadream »

Thank you for your feedback, I now switched the permission to have the location always available instead of only when using the app, will report back in case that didn't help.

Post Reply