Page 1 of 1

OpenVPN Client (paid) doesn't ignore SSID as it should

Posted: Tue Mar 12, 2019 11:31 pm
by yochaigal
Hello. I'm running 2.20.16 on a Pixel 3. It connects and works fine most of the time; however I've configured it to NOT connect on a specific SSID. Some of the time it works; but frequently I see it is connected on the SSID I have specifically told it not connect on.

Additionally, it seems to perform much slower than other VPN clients I've used on my Android phone; but I will make a separate post about that.

Thanks.

Re: OpenVPN Client (paid) doesn't ignore SSID as it should

Posted: Wed Mar 13, 2019 7:02 am
by admin
Hello,

on Android 8.1 and later the WiFi SSID is available only if the Android's Location (GPS) feature is enabled.
So, If the Location (GPS) is not enabled, the app cannot obtain the current WiFi SSID.

Re: OpenVPN Client (paid) doesn't ignore SSID as it should

Posted: Wed Mar 13, 2019 11:21 am
by yochaigal
GPS is enabled, and the app has permission for it

Re: OpenVPN Client (paid) doesn't ignore SSID as it should

Posted: Wed Mar 13, 2019 1:07 pm
by admin
Do you have selected the option "Disconnect when the WiFi is down"?
This option must be selected, otherwise the VPN is not disconnected.

Re: OpenVPN Client (paid) doesn't ignore SSID as it should

Posted: Wed Mar 13, 2019 1:15 pm
by yochaigal
Yup!

Here is a screenshot.
Screenshot (Mar 13, 2019 9_13_49 AM).png
Screenshot (Mar 13, 2019 9_13_49 AM).png (123.29 KiB) Viewed 341 times

Re: OpenVPN Client (paid) doesn't ignore SSID as it should

Posted: Wed Mar 13, 2019 1:37 pm
by admin
The configuration seem ok.
The VPN log show also the connectivity change events and the auto connect actions.
These log messages should explain the reasons of the VPN connection.
Please, can you check the VPN log?