Page 1 of 1

Phone will not enter deep sleep when OpenVPN is running

Posted: Sat Mar 30, 2019 1:46 am
by pharbrian
I am using the OpenVPN client on a Samsung Galaxy s9+ running android pie (Samsung OneUI). I have noticed that my phone battery is draining much more quickly after the OneUI update. I have narrowed it down to when the OpenVPN client is running. On android oreo, I could set the wifi to turn off when the phone was asleep. The new version of android does not have the feature.
In regards to the battery draining, I have noticed that my phone will not enter deep sleep, according to the AccuBattery app that tracks that statistic, when OpenVPN is running.
If I have wifi on when OpenVPN is not running, my phone will enter deep sleep for approximately 80-90% of the time when the phone screen is off.

Is there a setting I can change with the OpenVPN app that will allow my phone to enter deep sleep and thus improve the excessive battery drain that I have been experiencing. I see the option to pause the VPN when the screen is off, but I'm concerned that it will allow wifi traffic to be processed without VPN protection, or just block traffic altogether. I would prefer that it disables wifi traffic and allow it to be routed via cellular data instead (e.g. LTE data.)

Thank you for your assistance.

Re: Phone will not enter deep sleep when OpenVPN is running

Posted: Sat Mar 30, 2019 7:16 am
by admin
Hello,

this problem cannot be solved in the app, because the app cannot force the deep sleep.

Maybe I can add a new option to switch off the WiFi when the screen is off, but I have to think about it...

Re: Phone will not enter deep sleep when OpenVPN is running

Posted: Sat Mar 30, 2019 9:12 am
by pharbrian
Thank you for your consideration.

Re: Phone will not enter deep sleep when OpenVPN is running

Posted: Sat Mar 30, 2019 10:42 am
by admin
you're welcome.