DLNA transverse issue with TAP

Support requests about OpenVPN Client
Post Reply
Cantenna
Posts: 11
Joined: Mon Dec 16, 2019 12:33 am

DLNA transverse issue with TAP

Post by Cantenna » Tue Dec 17, 2019 10:24 pm

I'm having issues with getting DLNA to transverse with TAP on OpenVPN client on my One Plus Pro 7 (Oxygen OS Pie) and my Xperia Tablet (Poluux Windy running LineageOS Pie) Other proctols like HTTP,HTTPS,FTP,SSH work great, just seems to be an issue with DLNA (multicast packets).

If I instead use my my One Plus Pro 7 as a hotspot for my Surface Pro 4 (Arch install) and make the connection on the Surface Pro using the same config/cert/keys used above on the Android devices, DLNA comes through fine and works as intended with kodi.

On my Android devices I am testing with Kodi and VLC which see DLNA fine when connected via WiFi.

Any clues what the issue may be? I've had this working about a year ago with the same config but on Nougat... wondering if Oreo and Pie complicated things.

admin
Site Admin
Posts: 517
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: DLNA transverse issue with TAP

Post by admin » Wed Dec 18, 2019 8:10 am

The DLNA protocol discover the devices by sending packets to the multicast address 239.255.255.250.
So, maybe the problem can be solved by adding a route for this address. Here the steps:
  • edit the VPN profile
  • tap on "IPv4 routes"
  • tap on "+" button
  • set "Destination" field to "239.255.255.250" and "Subnet mask" field to "255.255.255.255"
  • save the changes

Cantenna
Posts: 11
Joined: Mon Dec 16, 2019 12:33 am

Re: DLNA transverse issue with TAP

Post by Cantenna » Wed Dec 18, 2019 10:53 pm

Your the best mate! Your suggestion worked flawlessly for me!!!

Merry Christmas!

:D :D :D

Cantenna
Posts: 11
Joined: Mon Dec 16, 2019 12:33 am

Re: DLNA transverse issue with TAP

Post by Cantenna » Thu Dec 19, 2019 8:06 am

@admin

So more testing, turns out the suggestion you mentioned above was not the solution that got DLNA to transverse over TAP for me using your app. Still appreciate the help though.

What gets it working for me on my devices;
*for some reason I have to enable tethering!? Even if I don't connect to the hotspot, just simply enabling it, Plex DLNA service suddenly becomes visible.

(Earlier when you gave me your advice I forgot I was hotspoting in the car for Netflix on another device....)

Any ideas why it's necessary to enable tethering? Would love to get this to work without having to activate hotspot

admin
Site Admin
Posts: 517
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: DLNA transverse issue with TAP

Post by admin » Fri Dec 20, 2019 3:13 pm

This is very strange. The tethering should not interfere with the VPN.
Anyway, I'm sorry but I have no idea why this happen and how fix it.

Cantenna
Posts: 11
Joined: Mon Dec 16, 2019 12:33 am

Re: DLNA transverse issue with TAP

Post by Cantenna » Sat Dec 21, 2019 7:38 pm

What an odd problem to have. If I figure it out will let you know.

Cantenna
Posts: 11
Joined: Mon Dec 16, 2019 12:33 am

Re: DLNA transverse issue with TAP

Post by Cantenna » Sun Dec 22, 2019 8:23 pm

@admin

More testing done; seems to be my One Plus Pro 7 that's the issue. I tried on an S8+ and it works as intended.

Even more strange, if I hotspot the S8+ and connect to it with my One Plus Pro 7 and vpn from the One Plus Pro 7, its works fine too.

So a bit of a win here;
-I know know this isn't an issue with my Server
-I suppose I can try different roms
-Your aware of the issue :D

admin
Site Admin
Posts: 517
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: DLNA transverse issue with TAP

Post by admin » Mon Dec 23, 2019 5:19 pm

Thank you for the informations

Post Reply