Auto-connect not working correctly

Support requests about VPN Client Pro
Post Reply
rcicerelli
Posts: 1
Joined: Wed Feb 12, 2020 8:43 am

Auto-connect not working correctly

Post by rcicerelli » Wed Feb 12, 2020 8:51 am

I have the client set to Connect when mobile connectivity is up and connect when the Wifi is connected but not to these SSID. When disconnecting from Wifi and going to mobile connectivity it connects automatically. However when I connect to Wifi to the SSID that I set to NOT connect I see view the log and I see entries like below repeatedly:

Connecting to 71.XXX.XXX.XXX:443
Set TLS SNI extension to "vpn.domain.tld"
SSL Connection timeout
Wait seconds...

Which means it's constantly trying to connect to the VPN even though it shouldn't try because I'm connected to the SSID that I set it to not connect. The only way I can this behavior to stop is to pause it when I'm connected to that SSID.

This is SSTP profile BTW.

Thanks

admin
Site Admin
Posts: 529
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: Auto-connect not working correctly

Post by admin » Wed Feb 12, 2020 9:37 am

Did you also select the option "Disconnect when the WiFi is down"?

This option disconnect the VPN also when the current SSID is not allowed, so without this option the VPN is not disconnected.

Post Reply