Automatic disconnect does not work

Support requests about VPN Client Pro
Post Reply
Doro1981
Posts: 1
Joined: Tue Nov 26, 2019 6:05 pm

Automatic disconnect does not work

Post by Doro1981 » Tue Nov 26, 2019 6:19 pm

I am using the connect on demand feature for my wireguard VPN, which works fine. The automatic disconnection, if connected to certain WiFi SSID works well too.
I would like to access a single address in the VPN network to retrieve some data, which takes less than a second. After that, the connection can be closed again. Under Global options/VPN options I checked Disconnect when the VPN is inactive with the parameters 10 seconds and 1024 bytes. So I expect to drop down the connection after 10 seconds. But even after minutes the connection is alive. I checked the throughput in the monitor (unter STATUS), which was verifiable nothing.

So any idea about this behaviour?

admin
Site Admin
Posts: 492
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: Automatic disconnect does not work

Post by admin » Tue Nov 26, 2019 6:58 pm

I will take a look tomorrow...

admin
Site Admin
Posts: 492
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: Automatic disconnect does not work

Post by admin » Wed Nov 27, 2019 8:58 am

You're right.
I forgot to implement this feature in the WireGuard backend.
The problem will be fixed in the next release.
I think that it will be available the next week.
Thank you for the bug report.

admin
Site Admin
Posts: 492
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: Automatic disconnect does not work

Post by admin » Tue Dec 03, 2019 4:44 pm

The problem has been fixed in new release 1.00.30
Please, update the app.

Post Reply