Automatic disconnect does not work

Support requests about VPN Client Pro
Doro1981
Posts: 2
Joined: Tue Nov 26, 2019 6:05 pm

Automatic disconnect does not work

Post by Doro1981 » Tue Nov 26, 2019 6:19 pm

I am using the connect on demand feature for my wireguard VPN, which works fine. The automatic disconnection, if connected to certain WiFi SSID works well too.
I would like to access a single address in the VPN network to retrieve some data, which takes less than a second. After that, the connection can be closed again. Under Global options/VPN options I checked Disconnect when the VPN is inactive with the parameters 10 seconds and 1024 bytes. So I expect to drop down the connection after 10 seconds. But even after minutes the connection is alive. I checked the throughput in the monitor (unter STATUS), which was verifiable nothing.

So any idea about this behaviour?

admin
Site Admin
Posts: 529
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: Automatic disconnect does not work

Post by admin » Tue Nov 26, 2019 6:58 pm

I will take a look tomorrow...

admin
Site Admin
Posts: 529
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: Automatic disconnect does not work

Post by admin » Wed Nov 27, 2019 8:58 am

You're right.
I forgot to implement this feature in the WireGuard backend.
The problem will be fixed in the next release.
I think that it will be available the next week.
Thank you for the bug report.

admin
Site Admin
Posts: 529
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: Automatic disconnect does not work

Post by admin » Tue Dec 03, 2019 4:44 pm

The problem has been fixed in new release 1.00.30
Please, update the app.

swejuggalo
Posts: 4
Joined: Thu Feb 13, 2020 9:19 pm

Re: Automatic disconnect does not work

Post by swejuggalo » Thu Feb 13, 2020 10:09 pm

Using an OpenVPN.

Of some reason Automatic connect does nothing for me.

The rules in On demand works fine. It disconnects when connecting to ssids I added. So the VPN is on everywhere else.

I would however like to use auto connect instead to define rules so all wifi connections other than the ones I've added as trusted. Nothing I do in Auto connect seems to work.

What am I doing wrong? Or is there a OpenVPN issue?

Android 10, OnePlus 7 Pro.

Ignore the post I tried to post in the wrong area 😜

admin
Site Admin
Posts: 529
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: Automatic disconnect does not work

Post by admin » Fri Feb 14, 2020 8:37 am

Do you use both Connect on demand and Auto connect features?
If so, please try to disable the Connect on demand.

Otherwise...
Is the VPN not connected automatically?
Is the VPN not disconnected automatically?

swejuggalo
Posts: 4
Joined: Thu Feb 13, 2020 9:19 pm

Re: Automatic disconnect does not work

Post by swejuggalo » Fri Feb 14, 2020 4:25 pm

Tried with only auto connect. Can't seem to get anything working but on demand.
Still better than OpenVPN Connect and OpenVPN for Android 😀

swejuggalo
Posts: 4
Joined: Thu Feb 13, 2020 9:19 pm

Re: Automatic disconnect does not work

Post by swejuggalo » Fri Feb 14, 2020 4:39 pm

Just tried to use the rules connect when mobile connectivity is up and connect when connected to WiFi but not my own and work SSID. It connects when dropping wifi. But it does not disconnect when reconnecting wifi. It's a hidden SSID. Could that be an issue?

Made it visible. No difference.
When reconnecting my wifi it just reconnects to VPN instead of following the rules.
Screenshot_20200214-174418.jpg
Screenshot_20200214-174418.jpg (252.64 KiB) Viewed 64 times

admin
Site Admin
Posts: 529
Joined: Fri Feb 15, 2019 4:04 pm
Contact:

Re: Automatic disconnect does not work

Post by admin » Fri Feb 14, 2020 5:02 pm

Please, select also the option "Disconnect when the WiFi is down".
This option disconnect the VPN also when the SSID is not allowed.

swejuggalo
Posts: 4
Joined: Thu Feb 13, 2020 9:19 pm

Re: Automatic disconnect does not work

Post by swejuggalo » Fri Feb 14, 2020 9:44 pm

Tried this profile. It did not connect just as it should. Then I removed swejuggalo just to simulate a unknown SSID.
It connected as it should. So it seems this config would connect to all SSID other than those I added on the list. Correct? More testing tomorrow.
Screenshot_20200214-223852.jpg
Screenshot_20200214-223852.jpg (246.96 KiB) Viewed 59 times

Post Reply